Xero - Dataset fetching fails for a number of companies in Production and UAT
Incident Report for Codat
Resolved
The incident has now been resolved, ongoing monitoring has shown the platform has returned to normal stability.

All users previously affected should be able to fetch Xero data without disruption.
Some users affected may want to queue a new sync for previously failing data types if they do not have a regular sync frequency scheduled. If they already have a sync frequency like daily or hourly, the next sync should be successful and there's no further action to take.

If you are still affected by this issue, please contact support@codat.io
Posted Jun 24, 2022 - 00:30 BST
Update
We are continuing to monitor for any further issues. Affected users should now notice that all Xero fetches are successful.

Our teams continue to monitor the platform to ensure continued stability. If you experience any issues please contact support@codat.io for further assistance.
Posted Jun 24, 2022 - 00:15 BST
Monitoring
We have implemented a fix in both UAT and Production environments.
Posted Jun 24, 2022 - 00:14 BST
Investigating
We are actively investigating an issue preventing datasets from fetching successfully for Xero in both Production and UAT.

Affected users will notice that some Xero datasets intermittently return a 500 error.
Posted Jun 23, 2022 - 23:09 BST
Identified
We have identified the issue and are working on a fix.
Posted Jun 23, 2022 - 23:08 BST
This incident affected: Integrations (Xero).