Push and Pull For the Xero integration are now working again as expected.
Our teams continue to monitor the platform to ensure continued stability. If you experience any issues please contact support@codat.io for further assistance.
Posted Jul 22, 2026 - 15:34 BST
Investigating
We are actively investigating an issue preventing users from Pulling and Pushing Data to Xero.
Affected users will notice that all Xero Push and Pull Operations result in an error.
This incident will be updated as soon as we have identified the issue, and no later than 16:09
Posted Jul 22, 2026 - 15:11 BST
This incident affected: Spend Insights (Xero), Custom Product CF3A11B4-ACC3-4BC2-B498-64A9F638311C (Xero), Bank Feeds (Xero Bank Feeds), Expenses (Xero), Sync For Commerce (Xero), Custom Product C9ECB109-8C62-4595-9130-849B710CFE14 (Xero), Sync For Payroll (Xero), Bill Pay (sync) (Xero), Bill Pay (async) (Xero), Custom Product F74BC050-CE30-4CF3-A1F6-7D5F3B5F7BD9 (Xero), Legacy - Accounting API (Xero), and Lending (Xero).