API timeouts and dataset completion delays
Incident Report for Codat
Resolved
Performance has returned to normal and datasets are now processing normally.
Posted Jul 04, 2019 - 14:17 BST
Monitoring
Microsoft's engineers have identified a cause of the Azure issue which is currently affecting Codat and are applying mitigations. We're seeing improvements across the board and Codat performance is returning to normal.

We are continuing to monitor the situation and the next update will be at 15:00 BST.
Posted Jul 04, 2019 - 13:00 BST
Update
Microsoft's engineers are continuing to investigate the underlying Azure issue which is currently affecting Codat.

Please note that datasets which are normally queued automatically (based on your Sync Settings in the Codat portal) are being queued with a reduced frequency. If you need a new sync to ensure data freshness, please queue a sync manually using the portal or API.

The next update will be at 13:00 BST.
Posted Jul 04, 2019 - 11:35 BST
Update
We are continuing to monitor the underlying Azure incident and mitigate the impact where we can. Next update at 11:30 BST.
Posted Jul 04, 2019 - 10:38 BST
Identified
Our engineers have investigated the issue and confirmed that we're being affected by an underlying Azure incident. We are currently working to mitigate the impact but you may still see delays in data synchronisation.
Posted Jul 04, 2019 - 09:55 BST
Investigating
Our engineers are investigating an issue causing datasets to get stuck in ProcessingQueued.
Posted Jul 04, 2019 - 09:28 BST
This incident affected: Cloud Accounting Integrations (Xero, QuickBooks Online, Sage Business Cloud, FreeAgent, Exact, MYOB Essentials, Kashflow, Freshbooks, Clearbooks), On-Premise Accounting Integrations (Sage 50, QuickBooks Desktop), Banking Integrations (TrueLayer, Tide), and Codat API, Codat Portal.