NetSuite Integration intermittent failures fetching and pushing data
Incident Report for Codat
Resolved
The incident has now been resolved, ongoing monitoring has shown the platform has returned to normal stability.

All users previously affected should be able to sync billCreditNotes, invoices, creditNotes and directIncomes datatypes from NetSuite and push bills to Netsuite without disruption.

If you are still affected by this issue, please contact support@codat.io
Posted Oct 14, 2024 - 14:54 BST
Monitoring
We have implemented a fix in production.

The most severely impacted users should now notice that billCreditNotes, invoices, creditNotes and directIncomes datasets complete successfully for NetSuite.

Our teams continue to monitor the platform to ensure continued stability. If you experience any issues please contact support@codat.io for further assistance.
Posted Oct 11, 2024 - 20:10 BST
Identified
We have identified the cause of the incident and are currently implementing a fix to remediate the issue.

This incident will be updated as soon as we have successfully tested and rolled out a fix in production.
Posted Oct 11, 2024 - 18:17 BST
Investigating
We have identified the cause of the incident and are currently implementing a fix to remediate the issue.

This incident will be updated as soon as we have successfully tested and rolled out a fix in production.
Posted Oct 11, 2024 - 18:10 BST
Identified
We believe that we have identified the root cause of this issue and working on deploying a fix asap.
Posted Oct 11, 2024 - 16:26 BST
Update
We are continuing to investigate this issue.
Posted Oct 11, 2024 - 16:25 BST
Investigating
We are actively investigating an issue whereby we are observing a higher than normal proportion of data fetches from NetSuite failing. This is also affecting some push operations.

Affected users will notice that some billCreditNotes, invoices, creditNotes and directIncomes datasets for NetSuite connected companies may fail with a Fetch Error as well as Bill push operations.

This incident will be updated as soon as we have identified the issue, and no later than 16:40
Posted Oct 11, 2024 - 15:42 BST
This incident affected: Sync For Payables (Oracle NetSuite), Supplier Enablement (Oracle NetSuite), Accounting API (Oracle NetSuite), and Lending API (Oracle NetSuite).