QuickBooks Desktop Push Operation Outage

Incident Report for Codat

Resolved

This incident has been resolved. Pushing to QBD is now working as expected.
Posted May 29, 2026 - 15:50 BST

Monitoring

We have implemented a fix. Affected users should now notice that their QBD push operations now no longer fail with an error message referencing a Third Party Gateway.

Our teams continue to monitor the platform to ensure continued stability. If you experience any issues please contact support@codat.io for further assistance.
Posted May 29, 2026 - 15:07 BST

Investigating

We are actively investigating an issue preventing users from push items to QuickBooks Desktop

Affected users will notice that their push operations are failing with 'Third-party gateway responded with an erorr status but did not return a valid error body'

This incident will be updated as soon as we have identified the issue, and no later than 16:03
Posted May 29, 2026 - 15:03 BST
This incident affected: Expenses (Sync For Expenses Connectivity, Dynamics 365 Business Central, Oracle NetSuite, QuickBooks Online, Xero, Sage Intacct, Zoho Books, QuickBooks Desktop, FreeAgent), Bill Pay (async) (QuickBooks Desktop), and Legacy - Accounting API (QuickBooks Desktop).