Datasets stuck in ProcessingQueued and Processing
Incident Report for Codat
Resolved
We have released a fix for the dataset delays and aren't seeing any further issues with datasets getting stuck in ProcessingQueued or Processing.
Posted Jun 25, 2019 - 12:43 BST
Update
We continue to see some datasets taking several minutes longer than usual in the ProcessingQueued and Processing stages. Our engineers are working to identify any further issues causing these delays. Next update by 14:00 BST.
Posted Jun 25, 2019 - 11:54 BST
Monitoring
The backlog of datasets in the processing stage of the pipeline has been cleared and datasets should be flowing normally again now. We are continuing to monitor the situation.
Posted Jun 25, 2019 - 10:27 BST
Investigating
We are currently investigating an issue causing datasets from all platforms to get stuck in ProcessingQueued and Processing. Retrieving data which has already been synchronised is unaffected.
Posted Jun 25, 2019 - 09:54 BST
This incident affected: Cloud Accounting Integrations (Clearbooks, Exact, FreeAgent, Freshbooks, Kashflow, MYOB, QuickBooks Online, QuickBooks Online - Accounting API (External), Sage Business Cloud Accounting, Xero, Xero - Accounting API (External)), On-Premise Accounting Integrations (Sage 50, QuickBooks Desktop), and Banking Integrations (TrueLayer).