Datasets unable to process in Production for most users
Incident Report for Codat
Resolved
The incident has now been resolved, ongoing monitoring has shown the platform has returned to normal stability.

All users previously affected should be able to complete new syncs without disruption.

If you are still affected by this issue, please contact [email protected]
Posted Feb 17, 2024 - 18:32 GMT
Monitoring
We have implemented a fix in Production.

Affected users should now notice that new datasets are processing as expected. We are currently processing a small and decreasing backlog of affected datasets queued earlier this morning. Affected datasets earlier today should complete their processing within the next hour.

Our teams continue to monitor the platform to ensure continued stability. If you experience any issues please contact [email protected] for further assistance.
Posted Feb 17, 2024 - 10:29 GMT
Investigating
We are actively investigating an issue preventing most users from completing new syncs in Production this morning.

Affected users will notice that new datasets are indefinitely remaining in 'Queued' or 'Fetching' statuses and are not progressing to further states. All users should still be able to query existing data, link or sync without any disruption.

This incident will be updated as soon as we have identified the issue, and no later than 11am UK time.
Posted Feb 17, 2024 - 09:36 GMT
This incident affected: Lending API (Lending Connectivity), Sync For Expenses (Sync For Expenses Connectivity), Sync For Commerce (Sync For Commerce Connectivity), Bank Feeds API (Bank Feeds Connectivity), Sync For Payables (Sync For Payables Connectivity), Sync For Payroll (Sync For Payroll Connectivity), and Products (Lending API, Sync for Commerce, Sync for Expenses).