Suppliers for some Netsuite connections may be deleted

Incident Report for Codat

Resolved

The incident has now been resolved, ongoing monitoring has shown the platform has returned to normal stability.

If you are still affected by this issue, please contact support@codat.io
Posted Mar 28, 2025 - 21:06 GMT

Monitoring

We have implemented a fix in production.

Affected users should now notice that Netsuite Suppliers previously marked as deleted have been restored.

Our teams continue to monitor the platform to ensure continued stability. If you experience any issues please contact support@codat.io for further assistance.
Posted Mar 28, 2025 - 19:59 GMT

Identified

We have identified the cause of the incident and are currently implementing a fix to remediate the issue.

This incident will be updated as soon as we have successfully tested and rolled out a fix in production, and no later than 9:10pm GMT.
Posted Mar 28, 2025 - 19:33 GMT

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 19:08 GMT

Investigating

We are actively investigating an issue resulting in removal of previously synced Suppliers for some Netsuite connections.

Affected users will notice that a large number of Suppliers are marked as deleted.

This incident will be updated as soon as we have identified the issue, and no later than 9:10pm GMT.
Posted Mar 28, 2025 - 19:08 GMT
This incident affected: General Connectivity & Portal (API Connectivity), Sync For Payables (Oracle NetSuite), Sync For Payroll (Oracle NetSuite), Supplier Enablement (Oracle NetSuite), Sync For Expenses (Oracle NetSuite), Legacy - Accounting API (Oracle NetSuite), and Lending API (Oracle NetSuite).