Some Xero payments and billPayments datasets failing
Incident Report for Codat
Resolved
The incident has now been resolved, ongoing monitoring has shown the platform has returned to normal stability.

All users previously affected should be able to sync payments and billPayments from Xero without disruption.

If you are still affected by this issue, please contact [email protected]
Posted Jun 09, 2023 - 14:29 BST
Monitoring
We have implemented a fix in Production.

Affected users should now notice that payments and billPayments datasets for Xero complete as normal.

Our teams continue to monitor the platform to ensure continued stability. If you experience any issues please contact [email protected] for further assistance.
Posted Jun 09, 2023 - 12:49 BST
Identified
We have identified the cause of the incident and are currently implementing a fix to remediate the issue.

This incident will be updated as soon as we have successfully tested and rolled out a fix, and no later than 12pm BST.
Posted Jun 09, 2023 - 11:17 BST
Investigating
We are actively investigating an issue preventing some companies from syncing payments and billPayments datatypes from Xero.

Affected users will notice that datasets of these types for some companies will fail with a MapError.

This incident will be updated as soon as we have identified the issue, and no later than 12pm BST.
Posted Jun 09, 2023 - 11:03 BST
This incident affected: Accounting API (Xero).